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1 iCIM 

 iCIM synchronisation process 
The iCIM synchronisation was improved to allow to connect to an existing iCIM project an iCD model 

that already contains objects. This process is meant to facilitate the synchronisation of several iCD 

model to a single iCIM project. 

 iCD Opening 
1. Open the model developed on iCD.  

2. Select Extensions> IES iCD>IES iCIM Client>Advanced> Enable dangerous operations. 

3. Open iCIM web page: https://icim.iesve.com/trial/#/ 

4. Select Extensions> IES iCD>IES iCIM Client>Advanced> Manage Endpoints   

 
5. Click "Add New", paste iCIM URL, remove the asterisk and add: /gfc/ 

Click on "Check URL" and then on "Save".  

https://icim.iesve.com/trial/#/
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6. In the list of endpoints on the main screen, we can do “Export” to export the whole list (it will 

create a GeoJSON file). This can then be imported into other PCs. It is useful for sharing 

projects.  
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7. Synchronize the model with iCIM. You need to click on the Synchronize button (up and down 

arrow) on the iCD toolbar (it may ask for authentication). Select the "location to sync". Click 

on "Add New", enter your name and description and click on "Publish".  

NB: at the bottom, there is a tick to allow the partial upload of the model. 

 

 

8. Select a building or area in the model to view it in iCIM. iCD now allows users to 
synchronise only a part of the iCD model that is within an “Area of interest” (AOI). The AOI is 
a geographical zone that can be defined in iCD. The iCIM Synchronisation process can limit 
the synchronisation only to objects within an AOI. This can be particularly useful to 
synchronise several different iCD models (covering different geographical areas) into a single 
iCIM project or if multiple users are independently editing and synchronising specific parts of 
an iCD model. In order to use an AOI to synchronise a model, it is first necessary to create it 
in iCD. To create an AOI:  
Right-click on the building(s) to select> IES iCD> Area of interest>Add Selected 
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9. Now, to add, it is necessary to log out of iCIM in Extension>iCD>IES iCIM Client>Advanced> 

Clear all Settings. 

Click on the double arrow and create a new project. For the synchronisation process to 

consider only the changes that occurred within the AOI, the box Limit to the buildings inside 

the baseline Area of Interest? Should be ticked. 

 

 

 

 

 iCIM Opening  
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Open iCIM (https://icim.iesve.com/trial/#/). By clicking on the iCIM symbol in the top-left 

part of the screen, you can access the User Guide, which is the iCIM online guide. 

 

 

 
 

By clicking on the four lines on the button to the right "Open" I can: 

 

1. Rename the selected project. 

2. Delete the project, which goes to the deleting page, and from there I can delete it 

permanently or even open it. 

3. Make the project public or add people to the project and I can give privileges through 

"Manage Users".  

4. Publish it via "Publish" so everyone can see it.  

5. Open the project via "Open" and the Welcome page opens. It explains the ways in which it is 

possible to move in the model. 

 

Below an example to explain the interface. 

https://icim.iesve.com/trial/#/
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- Bottom 2021 is the scenario synchronization period 

- Above, the sun creates shadows of the buildings. 

- The camera is used to save views 

- The layer button is to see the various layers of iCD 

- “Filter” to filter the model based on some conditions. If I want, I can select several filters 

at once. 

- Analysis that colours buildings based on metrics. It is possible to change the minimum 

and maximum values that can be displayed. With "Metrics Comparison", it is possible to 

compare the different scenarios that were simulated on the iCD. 

You can click on a single building and drill down into the results for that building. In the 

"Attributes" it is also possible to click on "Edit". This is in case I made a small change in the 

model and I don't want to upload the entire model into iCIM.   

  

 

 Import iCIM model to iVN 
Open iVN and click on the left bar on Import > iCIM Link. Put the link 

(https://icim.iesve.com/trial/gfc/), and login to IES. The projects will appear below. Furthermore, 

below, it is possible to indicate the start and end dates of the simulations I want to import.  Finally, 

you can import all the data from the selected model. 

https://icim.iesve.com/trial/gfc/
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2 iVN 

 iVN Setup  
After creating an account with iVN you must log in to your account to get access to the tool.  
 
After launching iVN, a browser window will open directing the user to the login page. Login to SSO 
platform via the browser by inputting account credentials. If an account has not already been created, 
the “Sign Up Now” button should be selected and a new password should be created along with 
entering the account email address.  
 
Note: The same email address as is assigned to the original iVN licence must be re-used here. A new 
email address will not be accepted.  

 New Project 
When opening iVN for the first time you are greeted with the iVN “Homepages”. This “Homepages” 
provides useful links to additional resources and learning material along with the most up-to-date 
version of the software (including notifications of available updates).  
To begin a new project from the “Homepages”, click on the ‘New’ tab located on the left-hand tab 

column. This will open a blank project from where you can start to build your network simulation. The 

blank project opens the three-dimensional sketching space where you can begin to physically draw or 

import the infrastructure required for your network set-up. 

 3D Model Viewer  
The 3D model viewer gives you the option to draw buildings/infrastructure to use within the network 

simulation. 

2.3.1 Draw Structures 
To begin the sketch mode, select ‘Draw Line’ icon from the tool ribbon. The ‘Draw Line’ tool will draw 

lines along the chosen plane using the specified points selected by the tool. It works by tracing the 

perimeter of the floorplan on the canvas. If you have a middle mouse button, you can pan the view to 

make drawing the line easier.  
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2.3.2 Import from OpenStreetMap 
From the “welcome screen”, the option is the “Homepages” to import buildings from OpenStreetMap 

is available from the import tab.  Locate the specific area you wish to import for your network using 

the OpenStreetMap. Highlight the desired infrastructure using the click and drag function to select the 

specific area to import (alternative highlighting tools are available in the left-hand corner). Once the 

desired area is selected, import the data by clicking ‘Import data’ in the bottom right-hand corner of 

the tab. 
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 Navigate the Interface  
The three main components of the interface are the Data inspector, the Simulation Hub and the 

Analysis Inspector.  

2.4.1 Data Inspector  
The data inspector is the primary method of inputting data and parameters to the network. Click on 

an asset within the network either by physically clicking the icon in the project viewer or by selecting 

it from the list in the project browser. The parameters of the assets can then be input for the specific 

network.  
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2.4.2 Simulation Hub 
The “Simulation Hub” contains the input parameters for the specifications of the intended simulation 

of the network. Here the length, reporting intervals and timesteps of the intended simulation are 

specified. Clicking the ‘Simulate’ button initiates the simulation.  

Note: In order to run a simulation, the network must be selected within the project browser.  

2.4.3 Analysis Inspector  
Once a simulation is complete, the results are accessible through the analysis inspector. From the 

analysis inspector the user can specify the particular set of results they wish to view by selecting them 

from the drop-down menu and then specifying the desired method of representation from the ‘Table 

Chart’, ‘Line Chart’ or ‘Bar Chart’ as shown below.  

 

 Virtual Network 
Virtual network nodes are used in the iVN to represent groups of assets and, when connected 

together, define a supply hierarchy in the form of a tree. Create a 2D virtual network view by clicking 

on the plus icon in the top left-hand corner of the “project viewer”. 
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From here, multiple views and scenarios can be used to provide alternative views of the project. To 

create multiple scenarios/virtual/physical network views, right-click on the network located in the 

Object Browser and select “Open in new virtual network view”. 

2.5.1 Creating a Virtual Network 
From the asset library tab located on the right hand of the project viewer, assets can be added by 

dragging and dropping into the virtual network viewer directly. 

Similarly, when using imported buildings, assets can be selected from the asset library and dragged 
directly into the project space (virtual network viewer).  
The Data Inspector will list every building that has a 3D geometry associated with it under the column 

"3D geometry". Dragging and dropping a building from the data inspector onto the virtual network 

view will add it to the virtual network, along with its floorplan. If 3D geometry is not available for a 

building, then the building can be added by dragging and dropping the "Building" asset from the asset 

library. If 3D geometry becomes available later for a building after the "Building" asset is added to the 

virtual view, then dragging and dropping the building listed under "3D geometry" in the data inspector 

onto an existing Building icon in the virtual network view will associate that geometry with the building 

asset, replacing the icon with the building's floorplan and relocating it to its geographical location. 

To define a virtual network, assets are connected to nodes that represent the commodities (electricity 

node, cooling node, heat node, potable water node, waste water node) that are produced or 

consumed. Nodes can also be connected to other nodes to represent different "levels" where demand 

is aggregated.  

2.5.2 Setting up a Virtual Network  
In order for a virtual network to be set up individual nodes must be added to the network. Each node 

within the network acts as an aggregation point allowing the network to be inspected and analyzed 

on several levels. By connecting nodes of the same type together, a tree hierarchy is defined. At each 

node in the tree, the demand is aggregated from all attached assets and this demand is met, as much 

as possible, by any attached generators. Any residual demand left over is then passed to the next node 

in the hierarchy, where it is included in the demand aggregation for that node. This computation is 

calculated in sequence, starting from the “leaves” of the tree and continuing until the “root” node. 

Any demand not met at the root node is assumed to be provided by an external supply. So, it's 

important which way we make the connections. The starting nodes have the highest hierarchy and 

are the starting points of the flow. See the image below. 
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Assets can be connected to nodes by left-clicking the small circle in the center of the node or below 

an asset and dragging a connecting line. Colored circles below assets indicate the type of node that 

the asset can be connected to. For example, a red circle indicates that an asset can connect to a heat 

node. If the small circle below an asset is white, e.g. for buildings, then the asset can have 1-to-many 

connections with many different node types. However, an asset can only have one connection to a 

node of a particular type.  

The parameters for each individual asset can be defined by clicking on the asset and using the data 

inspector. The demand and generation profiles can then be set for specific commodities by opening 

the ‘Demand and generation editor’ (access the editor by double clicking the asset / right clicking and 

selecting ‘Set demand and generation’). This dialogue is available for buildings and generic 

installations. 

Once the desired network is constructed and all parameters are inputted correctly, a network 

simulation can be conducted. 

2.5.3 Network Simulation 
Once the network is set up correctly, select the network as a whole in the project browser. Ensure the 

network parameters are correct using the data inspector. Set the desired network simulation 

parameters within the simulation hub tab: 

• Start date: DD/MM/YYYY 00:00-23:59 

• End date: DD/MM/YYYY 00:00-23:59 

• Time step: 1-60 

• Reporting interval: X ≥ Time step 

• Errors and Warning preferences. 

 

Now it is possible to click “Simulate”. The results, when the simulation has finished running, can be 

viewed via the “Analysis Inspector”. 
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 Physical Network  
In order to add assets to the physical network, they must first be present in the virtual network. Once 

present in the virtual network, assets can then be added to the physical network by right-clicking and 

‘Add to physical network’. 

In order to create a physical network, additional add-on licenses must be present: 

Heat: District Heat Network modelling allows for thermal energy design to be evaluated from a 

network infrastructure point of view and whether any changes or upgrades are required.  

Optimise: An optimisation problem can be set up by defining the objective(s) (e.g. minimize carbon 

emissions), variables and constraints to automatically give the optimal sizing of all assets in the design 

that satisfy the energy demand.  

 Import Function  
The ‘Import’ tab located on the “Homepages” provides the user with several options to import data 

into the iVN. 

2.7.1 iCIM Link 
Import a model from iCIM by loading the project's specific URL. Import from selected and specified 
start and end date. It is important to note that the iCIM endpoint to be copied and pasted into the 
import section shown below is as follows: https://icim.iesve.com/iesiclprojects/cim/project. 
Once this is done, a prompt will pop up to enter iCIM login details. From there then the list of iCIM 

projects will be selectable in list form. A project can be selected from the list and then the “Viewer” 

button is clicked and a pop up will appear that will show the area captured by the iCIM project. There 

is an option then to either select an area of interest to import in the same way that is done for the 

OSM import, or the entire area can be imported.  

 iSCAN Link  
iSCAN can be used to import metered time-series data or to create building benchmark data. To import 

time series data, the project URL and project API token links are required to be copied and pasted. 

Once this is done, log in to the iSCAN account through the pop-up dialogue. A list of channels will then 

appear and can be selected to import data between the dates defined in the bottom right corner.  

To generate the iSCAN API token and get the project URL, log in to iSCAN and navigate to the desired 

project, and select “API tokens” in the menu on the right of the screen. Click “Create Token” on the 

next screen, and when creating it ensure that the expiry date is long enough in the future that is 

suitable, and that the “Operator” role is selected. The import will not work if these options are 

incorrect. Once created, the API token link to the top and the project URL on the bottom of the screen 

can be copied and pasted into the iVN as described previously.  
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2.8.1 CSV Import  
Ability to import a timeseries profile in csv format into iVN. The timeseries can be utilised by the 

system and set as a profile to demand and supply units. When selecting a specific set of time series 

data in CSV format, the structure of the time series must be selected from the drop-down menu and 

imported in the appropriate format (“Row per profile” or “Column per profile”). 

“Row per profile” structure is shown below;  

 

“Column per profile” structure is shown below;  

 

Once the profiles have been imported, they are then available to be specified as time series data for 

demand/supply assets within an iVN Network.  
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By double clicking the desired asset or by right clicking the asset and selecting ‘Set demand and 

generation’ a profile can be added and the parameters set for its intended use within the ‘Demand 

and generation editor’.  

2.8.2 Weather Data  
iVN Energy simulations require reference weather data for the location of the building. A set of 

standard simulation weather files is included within the iVN installation, or it can read any *.fwt or 

*.epw simulation weather file. Resources are provided here to give routes to acquire additional 

weather files that may be used in simulations.  

To load a weather file from the install set, click on “Homepages” >> Import >> Weather Data then click 

the Browse icon. Model location parameters (latitude, longitude, elevation, and time zone) need to 

be set. This looks initially at any files saved inside the iVN weather files folder, but you may browse to 

a new file you have saved anywhere else on your local machine. When the desired file is set, you can 

then click Import to bring it into the project ready for simulation.  

3 iSCAN 

 Project Setup  

3.1.1 Building Details  
The Building > Building Details page is used to edit information about the project, such as name, 

sample period, time zone, etc. This is also where the location and altitude of the site are added. This 

information may be used to obtain weather data for the site location.  

3.1.2 Weather  
Once the site location and altitude are entered to the Building > Building Details page, the weather 

data may be obtained. This is done from the Data > Weather page. 

Highlight the dates for the required year(s) and select Populate Historical Data. Once populated, this 

data will be available in the iSCAN project. 

To enable automatic updates of weather data, select the checkbox for Enable automatic weather 

updates. Weather forecasts may also be enabled here for a maximum of 5 days by entering the 

number of days to forecast by. 

 Data Import  
Data may be imported via the Data > Import tab for a range of formats including: 

• Manual imports (CSV, XML)  

• Automated Imports ((SCAN Robot, web service connections, dedicated IoT connections e.g. 

MQTT, LoraWAN etc.)  

https://www.iesve.com/support/ivn/weatherfiles
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 Channel Settings 
Once data has been imported to iSCAN, it will be available as Channels, and is displayed on the Data > 

Channel List page. Each channel represents a dataset containing timeseries data. 

Channels will always be visible on the left-hand side of the screen. When a channel is selected, 

information about that channel will be available on the right. 

On the “Channel Setting” tab, information may be added to each channel to give more meaning to the 

channel data. This includes; the channel name, units, sample type, min and max values and export 

options. Notes may also be added to channels to share information with other project users.  

3.3.1 Tagging Channels  
Tagging channels allows the user to give more meaning to Channel data and organise the iSCAN 

project as desired. Tags can be added from the Project > Tag Vocabularies page. Once a tag vocabulary 

is created, tags can be added to the vocabulary. Tags may be applied to channels from the Data > 

Channel List page, from the Tags tab. 

3.3.2 Expressions  
Expressions allows the use of mathematical functions to derive virtual channels from measured data 

channels within the iSCAN project. iSCAN expressions use their own syntax, which more detail is 

available within iSCAN, from the Syntax link on the Channels Settings tab.  

In the Demo Project there are already some example Channels setup with the use of expressions. 

These are;  

• Total Electricity:  

This channel uses a simple expression, summing up the electricity metered from the three 

electricity sub-meters within the building.  

`Electricity Meter 1`+`Electricity Meter 2`+`Electricity Meter 3`  

This is useful in cases where some areas of a building are metered, but not all. Instead of installing 

additional meters, expressions may be used to derive “virtual meters” from existing data within 

the building.  

• Window Opening:  

This channel uses an expression to calculate a profile for window openings based on the outdoor 

air temperature and hours of occupancy.  

Building.`Occupied Hours` == 1 and Mean(Weather.`Dry Bulb Temperature`, 2 hr)>14? 1 : 0.01  

This means, when the building is occupied and when the outdoor dry bulb temperature is greater 

than 14℃ for more than a 2 hour period, the window is open. Outside of occupied periods it takes 

a value of 0.01 to account for leakage when windows are closed.  

 Visualise Tool  
The visualisation tool can be accessed from the Investigate > Visualise page and offers a range of plot 

types for different types of analysis. Some examples to try using the demo project include;  

• Calendar Tool  
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Select a channel measuring temperature from the channels list. On the calendar beneath the plot, 

select Quality. Days within the calendar will be color coded to show days with high vs. low data 

quality. 

• Heat Maps  

Plots types can be changes via the “Setting” tab on the Visualise page. Multiple channels can be 

selected at once using the CTRL key for each of the available plot types.  

4 PowerBI 
In order to create a roadmap for decarbonization, it is possible to use Power BI. Power BI is basically 

a free Microsoft tool, but IES created an RPI template to create a graph that represents the roadmap 

for decarbonization of a municipality.  

 

So what happens when new retrofitting is applied to all the buildings? What happens when applying 

a new HVAC system, or what happens when applying a certain retrofit in 2023 in 2025? In order to 

use Power BI, you need two templates: 

• MS PowerBI IES Roadmap template, which is the interface. 

• MS Excel IES Roadmap template, where you can put the data needed by PowerBI.  

 MS PowerBI IES Roadmap template 
So, starting with the MS PowerBI IES Roadmap template, it is possible to select the municipality in the 

interface. This is in case we are studying more municipalities. So, you can select the one that you are 

interested in. So, you have some high-level information about the municipalities and the square 

meters.  If you want to have a quick view of the ICD model, there is also a link that transfers directly 

to the online model. Going back to the roadmap, we have developed two types of roadmaps: carbon 

(CO2) and energy. So we can select one of them. Starting with energy, it gives the municipality MWh 

per year and how this parameter is changed, considering different energy efficiency scenarios to check 

the progress against what has been scheduled. The same consideration can be done for the carbon 

roadmap, but in this case, we have to consider the decarbonization factors. So, if you click over the 

different years, you can see the values of CO2 emissions, what the CO2 emissions are with no 
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interventions, and the cumulative CO2 savings that you are expected to achieve. The MS PowerBI IES 

Roadmap template is connected to a spreadsheet (MS Excel IES Roadmap template). So, in PowerBI, 

you can click “Transform Data” > ”Data Source Settings” and insert the file path where the spreadsheet 

is saved. So, every time you make changes in the spreadsheet, you just have to click on the “Refresh” 

button, and all the different values are uploaded in PowerBI. 

 

 MS Excel IES Roadmap template 
Now considering the MS Excel IES Roadmap template, as is written in the intro, you don’t have to 

touch the green values. Do not change the red values. You need to change the required data in black 

in each spreadsheet of the Excel file according to the municipality considered.  

 

Considering the “Overview” spreadsheet, which is about the Baseline, I have to insert the building 
name, building type, and location. About the Total floor area, I can see it directly in iCD. So, if I click on 
IES ICD > reports > ready-to-make reports > site report > full site report, the software shows the gross 
floor area. Then the software requires the Total Electricity and the Total Natural gas. These data can 
be found in the Energy Report of iCD baseline model. Furthermore, the table requires the latitude and 
longitude of the place (data that can be found on Google Earth). Then in “Image url” it is possible to 
insert a picture of the iCD model. So what I need to do is just to take a picture. Another important 
spreadsheet of the MS Excel IES Roadmap template is the “CO2 emissions factors”, where you have 
to update the electricity and the natural gas CO2 emission factors depending on the location and the 
progress projected year by year. Finally, we have the “P3 – Decarbonisation pathways” spreadsheet, 
where most of the changes happen. In the “date” column, it is possible to indicate when future 
scenarios are considered. Then there are the Electricity and Natural gas columns. From these, the Total 
energy and the CO2 emissions are automatically calculated, considering also the CO2 emission factors 
for the latter. Then there is a column about the “Implemented scenarios” in which it is possible to 
insert the target value of CO2 emission for each year. Furthermore, there is an “Intervention” column 
where to put the considered interventions (ex., residential renovation, PV, EV, etc.). Finally, there is 
the “Roadmap Type” column, which is “carbon” or “energy”, in order to allow the selection of different 
roadmaps. Note that for the Energy Road Type rows, in the CO2 emission column we will have the 
Total Energy values in MWh/year 
 
 


