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1 PART 1 

 iCD Installation 
1. Download SketchUp - version 2020 or higher (we highly recommend using the latest 

version). 

2. Download the latest iCD installer from the IES Download Centre. 

3. Launch SketchUp and go to Extensions → IES iCD → My IES Account → Log-in. 

4. For first-time access, you will need to create an account. Click "Sign up now," enter your 

email address, and create a password. 

o For more detailed instructions: see Installation and Licensing on the IES website. 

o Free on-demand training courses: "Getting Started with iCD " and “iCD Advanced 

Modelling" are available in the help section (last icon on the iCD toolbar). 

o Note: If you encounter issues, deselect the "legacy" license option in the iCD menu 

and restart SketchUp. 

 

 

After restarting, you can activate your account using the "My IES Account" button on the toolbar. 

First, you must register with the online Microsoft authentication database using your email. Once 

registered, log in with your credentials to activate your license. 

 Discovering iCD  
 

iCD is a master planning tool that allows detailed modelling or large-scale city-wide models, 

providing insights based on a wide range of data. 

https://www.iesve.com/support/icd/download
https://www.iesve.com/support/icd/installation-and-licensing
https://distance-learning.iesve.com/p/getting-started-with-icd
https://distance-learning.iesve.com/p/icd-advanced-modelling
https://distance-learning.iesve.com/p/icd-advanced-modelling
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1. Open SketchUp and create a new model. 

2. Enable the iCD toolbar (View > Toolbar > Tick IES iCD > Close)  

3. Enable the tag tray (Window > Default Tray > Ensure "Tag" tray is ticked), which will open 

the Layers of ICD. 

4. Open the ICD menu in Extensions (Extensions > IES iCD> Preferences). In the extension, you 

can, for instance, set the simulation engine, adjust the carbon emission parameters (kg CO2 

per kWh) and energy costs. 

There are two energy simulation engines available: IES VE and the IES iCD - Integrated Engine. The 

integrated engine is built into iCD and is now the default simulation engine. It offers the option to 

use the IES Apache engine if VE is not installed on the user's machine. The iCD integrated engine 

allows access to advanced attributes for the detailed input. 

You can choose between two types of simulation models: ASHRAE models and ICL models, each 

offering different attributes for building envelope performance or HVAC system details. 

For more details, visit Navigating the iCD plug-in. 

 Creating a model from an OSM import 
For urban or municipal-scale modelling, the fastest way to import large-scale geometry is using 

OpenStreetMap (OSM). iCD also supports GIS (GeoJSON) or Shape files, which will be covered in the 

next pages. 

To import OSM maps: 

1. Click the OSM Import button in the toolbar. 

2. Save your model in the desired folder.  

3. Search for the desired location (i.e. Milan) using the search bar or by navigating the map. 

4. Select the location and right-click on the map to "Place import site." The location is marked 

with a yellow pin. 

5. Set the import radius by clicking the yellow pin, saving the settings, and then selecting the 

import options. 

6. Click Import. 

 

For more details, visit OSM Import. 

https://help.iesve.com/icd2021/3__navigating_the_icd_plug_in.htm?ms=BQAAAAAIGA%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
https://help.iesve.com/icd2021/4_2_1__osm_import.htm?ms=AAAAAAA%3D&q=aW5jbHVkZSBsYW5kc2NhcGluZw%3D%3D&st=Mg%3D%3D&sct=MA%3D%3D&mw=MjQw
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 Creating geometry manually 
After importing OSM data, missing buildings can be manually added by either drawing from scratch 

or importing a DWG file (i.e. from cadastral maps). 

1. Draw the footprint using the Line Tool or Rectangle tool ; 

2. Use the Create button to access available objects, and select the building object. iCD will 

generate the corresponding building. 

 

3. Once the building is created, attributes can be added or modified. 

Note: Once the footprint is created, if you select all the zones and then generate the thermal zones, 

they will be connected. However, if you create the thermal zones one by one, they will remain 

separate. In either case, the attributes can be modified individually by clicking the "plus" button. 

If needed, the user can split these two buildings later. To do this, right-click on them, then go to IES 

iCD > Combine/Split > Split Up Objects. 

For more details, visit Creating objects from drawn polygons or Create geometry from a .dwg file. 

 Object attributes 
Once the geometry is imported from OSM and the missing buildings are manually added, we can 

modify the attributes of the created buildings using the Query Tool. 

1. Use the Query Tool. 

2. For each building, the following parameters can be modified (see pictures below): 

The Query Tool can be accessed through the toolbar :  
 

 
 

There is a list of attributes that can be amended using the query tool. These are also 
grouped by type (shown in the figure below), and there is also a choice to interact with the 
attributes at either a basic or detailed level, chosen through the toggle in the top right of the 
Query Tool. This is to accommodate both projects which have a limited amount of 
information on each building (e.g. regional energy plans with hundreds of buildings) or single 
building project where exact parameter values are available.  

https://help.iesve.com/icd2021/4_5__creating_objects_from_drawn_polygons.htm?ms=CQAAAAAQAQ%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
https://help.iesve.com/icd2021/4_6__create_geometry_from_a__dwg_file.htm?ms=CQAAAAAQAQ%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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See below example of The “Heating Source” . The attribute in the basic level sets the default 
values of the detailed attributes depending on the option selected. If the user then moves 
into that layer, they can set the values of those attributes manually.  
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The full list of attributes can be accessed here : 4.9. Editing Data 

It is not necessary to input all parameters to run the simulation. However, the more 

parameters you provide, the more precise and detailed the simulation will be. If no 

parameters are entered, iCD will use default values.  

In some cases, the user may have very important information for specific iCD buildings 
including Electricity & Gas Consumption Data’s, HVAC Data’s, Boiler’s Energy, Building 
Operational Cost etc. This available information can be incorporated to the corresponding 
buildings by creating new attributes using the customise option as explained here: 4.9.9.1. 
Create a custom attribute . We suggest applying this action just for specific cases. 
 

https://help.iesve.com/icd2025/4_9__editing_data.htm?ms=EQABAAAAEAEk&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
https://help.iesve.com/icd2025/4_9_9_1__create_a_custom_attribute.htm?ms=EQADAAAAEAEkCA%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
https://help.iesve.com/icd2025/4_9_9_1__create_a_custom_attribute.htm?ms=EQADAAAAEAEkCA%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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 Export and Import file CSV  
To further speed up the parameter modification process, we can use the CSV export feature. This 

allows us to select specific parameters for modification. You can edit these parameters directly in 

Excel or a similar program, and then re-import the CSV file with the updated parameters. 

We have created archetype files for the countries involved in the project to guide the selection of 

parameters. 

To proceed with the export and import of parameters, follow these steps: 

1. Export the CSV file in  Extensions > iCD > Import/Export > Export CSV with the Name (which 

will serve as the match key) and other attributes, such as the number of storeys, external 

wall, and external windows. 

2. Open the CSV file and make the changes using the archetypes to populate the data. 

3. Go to Import CSV, set the match key as the name, and assign the other attributes as existing 

attributes with the correct labels. 

Post-simulation consumption data can also be exported. If you do not select the "Aggregate results 

(exports only)" option, the exported data will be distributed monthly rather than as a total sum. 

  

For more details, visit CSV Import. 

 Data Painter and filters 
If there are buildings with similar characteristics, we can use the Painter Tool to apply parameters 

from one building to another. 

1. Click the Painter button in the toolbar. 

2. Select the source building and its object properties (e.g., storey height, roof type). 

3. The selected parameters will be displayed in the Verify Data section. 

4. Select the buildings where you want to apply the data (Paint Data to) and click Paint. 

Note: You can create custom filters to apply the data more selectively. To create a filter: 

1. Click on Open Editor > New (e.g., for residential buildings). 

2. Choose Primary Use and select options like Single-Family Detached, Single-Family Terraced, 

or Single-Family Attached. 

3. Click Apply and select the "Residential Buildings" filter, then click Show and paint the data. 

The parameters will only be applied to the buildings within the filter. 

https://help.iesve.com/icd2021/4_8_14__csv_import.htm?ms=GQABAAAQAQFQ&st=MA%3D%3D&sct=NDE1LjExMTExNDUwMTk1MzE%3D&mw=MjQw
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For more details, visit Data Painter. 

 Adjacent buildings  
If we want we can create adjacent buildings, which is an object type that can be used to model 

buildings which do not need to be subject to analyses. It is important to note that in iCD, adjacent 

buildings do not have the same level of details and do not carry as many attributes as regular 

buildings. No analysis can be performed on an adjacent building. However, adjacent buildings cast a 

shadow over buildings and have an impact on solar heat gain. 

To create Adjacent buildings, we can follow these steps: 

1. Draw the footprint using the “Line tool” or the “Rectangle tool”. 

2. Click on the Create button, select Adjacent Building under object type, and enter the 

relevant data. 

3. Click Create from Selection. 

 

In a similar way, by selecting a different object type, we can create:  

- Shades (Local, topographical and vegetated) 

Local shades, Topographical shades and Vegetated shades are objects that cast a shadow over 

building envelope / glazed areas. These object types can be used to model protection against 

radiative solar heat gain or natural landforms that alter the global solar exposure over a building. 

- Road 

Road is an object type used to model roads and streets in iCD. It is an essential object in order to run 

accessibility and walkability assessments. 

- Pavement/ Sidewalk 

Pavement / Sidewalk is an object type that allows modelling Pavement or sidewalks in iCD. In the 

absence of roads pavement can be used in order to run accessibility and walkability assessments. 

- Hard landscape 

https://help.iesve.com/icd2021/4_8_13__data_painter.htm?ms=GQABAAAQAQEQ&st=MA%3D%3D&sct=MzA4LjQ0NDQ1ODAwNzgxMjU%3D&mw=MjQw
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Hard landscape and Pervious hard landscape are object types that allow to model hard landscape 

elements in iCD, such as stones, rocks or pavement. Modelling a landscape as a Hard landscape or a 

pervious hard landscape has an incidence on site rainwater runoffs. 

- Soft landscape 

Soft landscapes (turf, shrubs, ground cover, mixed vegetation and wetlands) are object types that 

allow to model soft landscape elements in iCD. Modelling soft landscape depending on its type has 

an incidence on site rainwater runoffs. 

- Parking Bay 

Parking bay is an object type that allows the user to model parking lots in iCD. Modelling parking 

bays has an effect on site rainwater runoffs. 

- Water 

Water is an object type that allows the model bodies of water in iCD. 

 

For more details, visit iCD objects. 

 Point objects 
Point objects are elements that do not require a footprint to be created. This group includes items 

like photovoltaic panels (PV), lights, and charging stations. 

1. Click on the Create button, and select the point objects (e.g., PV). 

2. Add the relevant data. 

3. Click Create from Selection. 

Note: Duplicating point Objects: Point Objects can be copy-pasted using the traditional method (Ctrl 

+ C and Ctrl + V). To copy multiple Point Objects at the same time, use the command Ctrl + C x 

[number of point objects]. 

4. Example: Enter Ctrl + C x 10 to add 10 point objects to the model. 

Example 

- Click the Create Button, Create the PV, add the PV attributes, and position it in the 

model. 

- Click Create from Selection. 

Note: Once the solar assessment is completed, the results can be visualized in the report under 

Extensions > IES iCD > Reports > Ready-made Reports > Site Renewable Reports > Full Site. 

For more details, visit Object’s Geometry and Data Assignment. 

 Solar Assessment and Roof Solar Potential 
A method to speed up the implemetation of PV panels and their analysis is through the use of Solar 

Assesment. 

https://help.iesve.com/icd2021/4_1__icd_objects.htm?ms=DQAAAAAQQAE%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=NDUx
https://help.iesve.com/icd2021/4__object_s_geometry_and_data_assignment.htm?ms=BQAAAAAQGA%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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The Solar Assessment allows the user to generate insolation data based on the project's geographic 

location. Once the geo-location is set, the Solar Assessment can be accessed via Extension tab > IES 

iCD > Solar Assessment. 

The Solar Assessment can also be used to automatically populate the model with PV panels. Once 

the assessment is completed and the results are saved, the panel for planning and designing PV 

systems on various rooftops (PV attributes) will be unlocked. At this point, the relevant parameters 

need to be entered, as shown in the image. 

 

 

For more details, visit Photovoltaic (PV) panels. 

 Run Simulation Options 
The iCD Simulation Launcher enables users to conduct energy and water simulations using the VE 

calculation engine. These simulations generate data that can later be visualized through reports, in 

the visualization tool, or directly in the Query menu of each building.  

  

https://help.iesve.com/icd2021/4_9__photovoltaic__pv__panels.htm?ms=AQAAAAAQ&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw


 

 STEP-WISE GA N. 101120859 PAGE 12 

STEP-WISE TECHNICAL TOOLKIT USE CASE GUIDELINES  16.12.2024 - FINAL VERSION 

 

The general workflow for running simulations is as follows: 

1. Select the buildings you wish to simulate. 

2. Click the Simulation button in the toolbar. 

3. Choose the shading catchment options. 

4. Select the simulation options and click Update. 

5. Launch the simulation. 

For more details, visit: iCD Simulation Launcher. 

 Create a Model from GIS Files and CSV Files 
To the geometry creation, another method for creating geometry is by using GeoJSON or Shape 

files. GeoJSON is a widely-used topographical format that includes geometries and polygons. It 

contains various information, such as building names, locations, and heights. GeoJSON files can 

often be downloaded for free from government websites. 

GeoJSON files can be imported into the iCD model via Extension > IES iCD > Import/Export > Import 

GeoJSON (with attribute mapping). Once the GeoJSON file is imported, it can be enriched by 

incorporating and using a CSV file, as previously explained. 

1. Additional data to be added through CSV import: Number of storeys, primary use. 

2. CSV Import: the functionality is accessible directly from the toolbar via the below icon  

 
  

The CSV import is broken down into 5 steps described below.  

https://help.iesve.com/icd2021/5_4__icd_simulation_launcher.htm?ms=KwAAAAA0IAEE&st=MA%3D%3D&sct=NDA0LjQ0NDQ1ODAwNzgxMjU%3D&mw=MjQw


 

 STEP-WISE GA N. 101120859 PAGE 13 

STEP-WISE TECHNICAL TOOLKIT USE CASE GUIDELINES  16.12.2024 - FINAL VERSION 

Selecting CSV file  
At this step the user is asked to select the CSV file they wish to import.  

  
Selecting the match key  
At this step the user can choose the CSV column that will be used as a match key as well as 
the iCD attribute it will be matched against  

  
Reviewing the match  
The user can review the objects targeted by the CSV import based on the selected match 
key.  
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Attribute mapping   
At this stage the user defines which column in the CSV file is meant to be imported into 
which iCD attribute (existing attribute or by creating a new Custom attribute).  

  
Importing data  
The data are imported to model as part of this stage and iCD gives the user an overall 
feedback   
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3. Import the GeoJson File. 

4. Browse for the CSV File. 

5. Use UPRN as a matching key. 

6. Import the following columns: 

o Primary Use (Existing attribute, Option for primary use), 

o Number of Storeys (Existing attribute, Integer, Number of storeys), 

o Import other attributes as custom attributes (create a new list of strings and assign a 

name to each new attribute). 

7. Click Match. Once the match is made, click Assign. 

 

For more details, visit Data Import/Export. 

2 PART 2 

 Results visualisation 
 

The results of the simulation can be easily viewed in iCD using several methods: 

 

● Using the Query Tool: Navigate to the "Simulation Results" section. 

● Accessing Reports: Go to Extensions > IES iCD > Reports > Ready-made Reports, then select 

an appropriate report, such as Energy Reports > Full Energy Report. 

Note: 

 

● Each report's images or graphs can be saved as PNG files by clicking the arrow next to the 

graph title. The visuals can also be customized by adjusting the graph elements. 

● If the water simulation is completed, you can view the detailed water report, which includes 

various schematics. 

 

For more details, visit: Data visualisation and reports. 

https://help.iesve.com/icd2021/8__data_import_export.htm?ms=AQAAAAAQ&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
https://help.iesve.com/icd2021/6__data_visualisation_and_reports.htm?ms=AQAAAAAQ&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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 Scenarios 

iCD enables the comparison of multiple design options by analyzing them within a model to identify 

the optimal solution. It allows users to evaluate the effects of various parameters on both the water 

and energy performance of a project. To use the scenario tool follow the steps: 

1. Set Up the Base Case: The currently open model is considered the base scenario. Before 

creating any scenarios, make sure to run a simulation on the current model. 

2. Create a New Scenario: 

○ Go to Toolbar > Scenarios > select the base scenario > Duplicate, then give it a name 

(e.g., Scenario 1). 

○ Open Scenario 1 and make changes to the model, such as adding insulation to the 

walls. 

3. Simulate the Modified Scenario: 

○ Run the simulation again by clicking the Simulation button in the toolbar, selecting 

the building, using the Filter Selected Building Only option, clicking Update, and then 

Launch. 

4. Compare Scenarios: 

○ Click the Scenario button in the toolbar, select both scenarios, and choose Compare 

Selected to generate the Energy Reports > Full Energy Report. 

Note: After comparing, you can generate the Renewable Energy Report to view the different 

components. 

Examples Scenario: 

● Scenario 2: Add heat pumps and photovoltaic panels (PVs). 

● Scenario 3: Modify profiles and setpoints. 

● Scenario 4 (CO2): Enhance the environment by adding trees, green areas, etc. 

Experiment with different changes to see their effects on the project's performance. 

For more details, visit: Scenarios for comparative analyses. 

 Time Dimension e Multi-year simulation 
This feature can be useful for defining a model in relation to a previously dated scenario. If desired, 

with custom attributes, you can define the "Date Constructed" and "Date Demolished" to provide a 

complete overview of all buildings, even if that information is not available. If the "Date 

Constructed" and "Date Demolished" attributes do not appear, they can be unlocked by navigating 

to Extension > IES iCD > Attribute Visibility. 

1. Click on Time Dimension to visualize the buildings that have been demolished and 

constructed throughout the timeline. 

2. If you choose a specific date, once the scenario related to that date is run, the demolished 

and constructed buildings will be added to specific layers in iCD. You can access these layers 

by going to Extension > IES iCD > iCD Layers. 

https://help.iesve.com/icd2021/7__scenarios_for_comparative_analyses.htm?ms=AQAAAAAQ&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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3. If you navigate back in the timeline, you can modify all attributes (such as wall insulation, 

HVAC, etc.). When you return to the present, the attributes will revert to their current state. 

This is particularly useful for conducting Multi-Year Simulations. 

 

 

 

IES will execute all simulations for the selected years. When generating the report, you can choose 

the year you wish to display. The same applies to the Visualization Tool. 

 

For more details, visit: Time Dimension. 

 Basic Carbon Emissions Analysis   
In iCD, it is possible to perform a Carbon Emissions Analysis semi-automatically.  

1. First, you need to define the CO2 emission coefficient for each energy source in  Extensions 

> IES iCD > Preferences (i.e., Biogas, Electricity, etc.). 

2. After that, you can run the simulation, considering factors like trees and electric vehicle 

charging stations (you can select these three types for the simulation). 

https://help.iesve.com/icd2021/4_14__time_dimension.htm?ms=AwAAAAAQAQ%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw
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3. Select the three elements and view and modify the CO2 Emissions tab with the Query tool. 

4. Generate a report on carbon emissions by navigating to Extensions > IES iCD > Reports > 

Ready-made Reports > Site Renewable Reports > Full Carbon Emissions. 

Note: You can use the Boundary Tool to create trees and automatically generate them within the 

defined boundary. First, we need to create a new boundary. After creating the boundary as shown 

below, the Auto-Generate tree in the boundaries can be clicked.   

 

For more details, visit: Carbon analysis. 

 Basic Cost Analysis   
Like the carbon emissions analysis, iCD can also conduct cost analyses. 

1. In Extensions > IES iCD > Preferences, you need to define the current currency and the costs 

for each energy source used. 

2. After that, launch the simulation. If a simulation has already been completed, you can use 

those results.  

3. Once the simulation is complete, you can view the report by navigating to Extensions > IES 

iCD > Reports > Ready-made Reports > Site Reports > Cost Savings Breakdown. 

For more details, visit Basic cost analysis. 

 Creating a custom attribute 

The Customize feature in iCD allows users to create additional attributes for the model, enabling the 

incorporation of specific data as needed. 

1. Open the Customize Menu: Select Customize  from the iCD toolbar. 

2. Add a New Attribute: In the Custom Model Attribute window, click Add Attribute. 

3. Define the Attribute: 

○ Name: Enter the attribute's name (e.g., "Services"). 

○ Type: Choose the attribute type from the list (i.e. text, list, integer, true/false, or 

number) based on the requirement. 

https://help.iesve.com/icd2021/5_7__carbon_analysis.htm?ms=KwAAAAA0IAEE&st=MA%3D%3D&sct=NDA0&mw=MjQw
https://help.iesve.com/icd2021/5_6__basic_cost_analysis.htm?ms=KwAAAAA0IAEE&st=MA%3D%3D&sct=NDc2&mw=MjQw
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4. Set the Applicability: Determine where the attribute applies (e.g., to all objects, buildings 

only, floor plans only, rooms only, landscaping, or shading). The attribute will be available 

only for the selected category. 

5. Specify a Default Value: Set a default value for the attribute before saving the configuration. 

 

2.6.1  

● Example 1: 

○ Create an attribute named "Services" and select the type as List. 

○ Add items to the list (e.g., "Pharmacy," "ATM," "Supermarket") and save. 

○ Choose the newly created list, set a default value, and save the attribute. 

● Example 2: 

○ To indicate buildings equipped with electric vehicle charging stations, use a Boolean 

attribute (True/False). 

○ Alternatively, choose the Number type, define a unit of measurement (e.g., number 

of charging stations), and enter the data accordingly. 

This process ensures that custom attributes align with the specific needs of the project model. 

For more details, visit Create a custom attribute. 

3 PART 1 and 2 - Extra Features 

 Boundaries  
This tool simplifies the process of dividing a group of buildings into specific areas: 

1. Open the Boundary tool . 

2. Draw the Boundary: Outline the boundary around a building and any point objects. 

3. Create the Boundary: Click the Create button, then name the boundary. 

4. Use the Boundary Button: Access the Boundary option in the toolbar to finalize the 

boundary setup. 

https://help.iesve.com/icd2021/4_8_12_1__create_a_custom_attribute.htm?ms=OwAAAAA0IAEBFA%3D%3D&st=MA%3D%3D&sct=NDc2&mw=NDYx
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Note: 

● Reports: 

For large master plans, reports are valuable for visualizing partial model simulation results. 

To generate a report for specific areas, select the buildings within the defined boundary. 

● Using the Selection: 

The Selection Tool allows for a quick selection of buildings within the boundary. This is 

particularly useful for tasks such as simulating a subset of the master plan or modifying 

specific attributes. 

 

 Accessibility Assessment 
This tool is used to measure the distances between services or specific amenities within the model. 

The “Roads and Pavements” must be modelled and enabled. 

1. Navigate to Extension > IES iCD > Accessibility Assessment. 

2. Select the attribute and choose the corresponding value. Click on the map to set the desired 

location. 

For more details, visit: Accessibility Assessment. 

https://help.iesve.com/icd2021/2_3_5__accessibility_assessment.htm?ms=OwABAAA0IAEBFBA%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=NDYx
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 Walkability Boundaries 
iCD allows to perform a Walkability Assessment which shows the area covered under a 

given walking distance to a point in the model. The “Roads and Pavements” must be modeled 

and enabled. 

1. Click the Boundary button in the toolbar. 

2. Navigate to Boundaries > Generate Walkability Boundaries. 

For more details, visit: Walkability Assessment. 

3.3.1 Socio-Economic Indicators and Custom calculations 

The Socio-Economic Indicators dialogue allows the end-user to perform a series of 

calculations over a number of years, based on specific inputs. The user can use these 

calculations to generate values for the default socio-economic indicators or create their own 

custom indicators and calculations.  

  

Custom calculations (or Socio-Economic Indicators) are done at a boundary level. It is then 

necessary to have defined boundaries in the model prior to doing these calculations. 

There are two ways to access the Socio-Economic indicators Dialog: 

1. You can right-click on the desired boundary and select IES iCD > Socio-economic 

Indicators. 

2. Or open the Boundary tool in the tool bar. Select the desired boundary from the list by 

ticking the box on its left side. Then click Boundaries > Socio-economic indicators). 

 
 
For more details, visit: Socio-Economic Indicators and Custom calculations. 

  

https://help.iesve.com/icd2021/2_3_4__walkability_assessment.htm?ms=OwABAAA0IAEBFBA%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=NDYx
https://help.iesve.com/icd2021/5_5__socio_economic_indicators_and_custom_calculations.htm?ms=OwABAAA0IAEBFBA%3D&st=MA%3D%3D&sct=MTA2NA%3D%3D&mw=NDYx
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 Complex Geometry  
iCD allows the manual creation of complex geometry. 

1. The creation of Complex Geometry starts from a SketchUp model or an imported model. 

2. Right-click on your building and select IES iCD > Preview Geometry. Here, you can see how 

iCD interprets what you have drawn (thermal zone, local shade, etc.). 

3. To create your iCD Object, first right-click and select Make a Group to unify it into a single 

block, and then click the Create Object icon in iCD. 

4. It is important to correctly define the desired spaces at this stage and ensure that each one is 

represented by an appropriate bounded volume. 

● iCD interprets polygons (or circles) within a face that define a bounded volume as glazing. 

● iCD interprets faces that do not define a bounded model as local shades. 

 

 

Note: Once the iCD model is created,  it is possible to convert the iCD complex geometry into a 

SketchUp model and make changes as a SketchUp element. You can convert a simple geometry 

building into a Complex Geometry Building by following these steps: 

● Right-click on the building to open the contextual menu. 

● Go to IES iCD > Convert to Complex Geometry. 

● Double-click on the building to edit it. 

Note: models can be imported from VE as 3D AutoCAD drawings, from Blender, or from Rhino 

(exporting as SKP files). 

 

For more details, visit Object’s Geometry and Data Assignment. 

 

https://help.iesve.com/icd2021/4__object_s_geometry_and_data_assignment.htm?ms=BQAAAAAQGA%3D%3D&st=MA%3D%3D&sct=MA%3D%3D&mw=MjQw

